Camera wants to format card unless recently read on Mac

Help troubleshooting your Eye-Fi Card

Camera wants to format card unless recently read on Mac

Postby markjreed on Sun Feb 10, 2013 9:05 am

I have an Eye-Fi Pro X2 8GB and a Nikon Coolpix L26, both purchased two months ago.

Within the past few weeks, the camera stopped recognizing the card. I would take some pictures, turn off the camera, turn the camera back on (having left the card in the camera the whole time), and get a message saying the card needed to be formatted.

I removed the card, plugged it into my Mac using the Eye-Fi USB reader, and it was read fine - all the pictures showed up. I transferred them without deleting them or otherwise making any intentional changes to the card, ejected it from the computer, put it back in the camera - and the camera now recognized the card.

This scenario repeats every time I turn the camera off and back on. Camera says card needs to be formatted. I take card out and put back in - still needs formatted. Take card out, read on computer, put back in - card works. Turn camera off and back on, card needs to be formatted again.

I did actually reformat the card - once with the camera , once with the Mac - to see if that would help, but it doesn't seem to make a difference. It doesn't seem to be just the camera, since a regular 8GB non-Eye-Fi SD card is not exhibiting the same problem.

Any suggestions? If the Eye-Fi is bad, I don't know why the computer is not having any trouble. I also don't know what the computer is doing that makes the camera recognize it. I find the whole thing baffling.
markjreed
 
Posts: 1
Joined: Sun Feb 10, 2013 8:56 am

Return to Eye-Fi Card

Who is online

Users browsing this forum: No registered users and 3 guests